MATLAB Control System Toolbox Root Locus Design GUI

MATLAB Control System Toolbox® contains two Root Locus design GUI, sisotool and
rltool. These are two interactive design tools for the analysis and design of the single-
input single-output (SISO) linear time-invariant (LTI) control systems. sisotool opens the
SISO Design Tool with Root Locus View and Bode diagram. rlteol opens the SISO
Design Tool with only Root Locus view on. These GUI allows you to design
compensators by interacting with the root locus, Bode, and Nichols plots of the open-loop
system. To load an empty SISO Design Tool at MATLAB prompt type

>> sisotool

sisotool can also be called with additional arguments. For example, sisotool(Gp), or
sisotool(Gp, Gc). Where Gp is the plant object model and Ge is the compensator object
model.

You can import SISO LTI model into the Root Locus Design as follows:
e Load a model from the MATLAB workspace
e Load a model from a MAT-file
e Load the model from the SIMULINK diagram

Similarly, rltool opens SISO Design Tool with only the Root Locus View.

Following examples are used to demonstrate some of the features of the Root Locus
Design.

Example 1
In the control system shown G, (s) is a proportional controller, K .

y

R ) 1 C(s)
L G.(s) G,(s)= s(s+2)(s+5) }

|

Using sisotool determine the following:

(a) Range of K for system stability.

(b) Value of K for the complex dominant-poles damping ration of 0.6. For this value of
K obtain the frequency response GM and PM. Also obtain the step response and the
time-domain specifications.

To make the plant model and start the SISO Design Tool, at the MATLAB prompt type
>>Gp=tf(1, [1 7 10 0])

>> sisotool
An empty SISO Design Tool opens as shown.
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The compensatar C iz now in the fonaard path.

The SISO Design Tool by default assumes that the compensator is in the forward path.
The FS button toggles between two configurations, placing the compensator in the
feedback or forward path as shown above. Select Import Model under the File menu.
This opens the Import System Data dialog box, which is shown below. All the available
models will appear in the Model Listbox: The Blocks are coded as F (A preamplifier), G
(Plant model) H (Sensor), K (Compensator) with default values of 1.

Select Gp and click on the arrow button to place it in the G field.
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The Other button toggles between the two configurations. Click OK. The root locus and
open-loop Bode diagrams are displayed in the plot regions. The red squares on the loci
represents the closed-loop poles corresponding to gain set point (default value C(s) = 1).
Also the gain margin and the phase margin for the default gain of C(s) = 1 are listed on
the Bode plot.
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Impaorted model data. Right-click on the plats for desigh options.

The SISO Design Tool has right-click menus available in the plot regions with many
features.

Add PolefZern Feal Pole &dd PolefZern Feal Pole
Delete PolefZero Complex Pole Delete PolejZero Complex Pole
Edit Compensator, ., Integratar Edit Compensatar, ., Integratar
Design Caonstraints  k Real Zero Shiow 3 Feal Zero
arid Complex Zero P R Complex Zero
Zoom » Differentiakor Getzlgn OnStraints Differentiakor
Fi
Froperties. .. Lead Zoom 3 Lead
Lag P b Lag
roperties. ..
Mokch 5 Mokch

Right-Click Menu on the Root Locus plot
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You can change the compensator gain by typing a value in the C(s) field. Also, you can
change the gain by grabbing the red squares (closed-loop poles) on the root locus plot and
moving them along the curve to the desired location. To place the roots accurately in a
desired location first, select Zoom XY from the right-click menu; then select a region of
the root locus, hold and place a small square in the desired region. This will zoom in the
desired region. Alternatively you can use the Mouse Zoom from the Zoom icons on the
toolbar. Click on the Mouse Zoom icon (Zoom in XY), and then repeatedly click on the
desired location on the root locus for the necessary zoom. Turn off the Mouse Zoom.
Drag the closed loop pole to the desired location.

Zoomin X Zoomm ¥

e X XK

Zoomin XY Foom out

(a) To find the value of K for marginal stability drag the closed-loop pole along the
locus to the jw -axis intersect. Turn on the Mouse Zoom and drag the mouse to draw a

box around the pole. When the mouse is released, root locus will zoom in on the selected
region. Drag the pole to this accurate position. The gain for marginal stability is found to
be K, =70. A zoom out result is as shown.

<} SIS0 Design Tool O] x|
File Edit “iew Compensators Tools Window  Help

i xe 2 timz X0

Current Compenzator
| e
= 70 -
F5

+i-

oot Locus Editor (2 Open-Loop Bode Editor (2]
T T a0 T ——rrT T
10 ¢ .
m— - — - — - — - T - — - — - — - — ]
5t -
50 G 000405 dB 1
. Freg: 316 radfzec
0 B - - - PEESECESE Stable loop
-100 il
-an r .
5L i
80— -—-—-—- ]
A0t ] Pl 00122 deg
. . . ! 270 I?req:S.‘IEradJ’seuu: o 1 ——
e il = c S0 10 10 10
Real Axis Freguency [radizec)
Zoomed out.

Right-click on plots for more dezign options.
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(b) To find the gain for damping ratio of 0.6, drag the complex pole until the damping
ratio displayed in the bottom panel is in the neighborhood of 0.6. Then zoom in and drag

the pole until damping ratio

is 0.6. The result is as shown.
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Current lozation: -0.766 + 1.02

Cirag thiz clozed-loop pole along the locus to adjust the loop gain.

Damping: 0.6 Matural Frequency: 1.28 rad/sec

The gain is found to be K, =8.89. Also one of the complex pole and the natural

frequency are displayed in the bottom panel, i.e., s, =—0.766+ j1.02 and @, =1.28 rad/s.
In addition the Gain Margin and Phase Margin are displayed in the Bode plot area, i.e.,
GM =17.9dB, and PM =58.6".

From Tools Menu select Loop responses/Close-Loop Step to obtain the step response.
Right-click on the plot, and select Characteristics and then Rise Time and Peak
Overshoot. Left click on the blue dots, this will display the time-domain specifications

shown in the Figure below.
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Right-click. on the plot areas for more options.

Example 2

For the system in Examplel Design a PD compensator C(s) = K, + K s for the following

time-domain specifications.

¢ Dominant poles damping ratio £ =0.707
e Dominant poles settling time of #, =2 seconds

t,=4r=2 =  7=0.5second

(o, =—=—=2,and 6 =coc ' (0.707) = 45°
z 0.5
Therefore

To make the plant model and start the SISO Design Tool, at the MATLAB prompt type

>>Gp=tf(1, [1 7 10 0])
>> sisotool

An empty SISO Design Tool opens as shown
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The compensatar C iz now in the fonaard path.

Select Import Model under the File menu. This opens the Import System Data dialog

box. Select Gp and click on the arrow button to place it in the G field.
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Click OK. The root locus and open-loop Bode diagrams are displayed in the plot regions.
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Impaorted model data. Right-click on the plats for desigh options.

The SISO Design Tool provides design constraints that can make it easier to meet design
specifications. If you want

To place a pair of complex poles on your diagram at a damping ratio of 0.707, select
Design Constraints and then New from the right-click menu in the root locus. This
opens the Design Constraints editor. In the damping ratio field enter 0.707. This results
in a pair of shaded rays at the desired slope. To add a settling time constraint, reopen the
New Constraint window and choose settling time from the pull-down menu, set it’s filed
to 2. In order to have a closed-loop pole at s, =2+ j2, a zero must be added to shift the

loci towards the left-half s-plane. To add a zero, turn on the zero O on the toolbar and

place the zero\ o on the real axis just to the left of the pole with the smallest magnitude.
Move the closed-loop pole up the loci towards the intersection of ¢ and 7 constraints.

You can turn on the Mouse zoom and place a square in the area containing the controller
zero and the closed loop pole s, . Adjust the zero position on the real axis and at the same

time hold the left mouse and drag the closed-loop pole until the pole is placed at the
desired location as appears on the bottom panel.
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[irag thiz cloged-loop pole along the locus bo adjust the loop gain.
Current location: -2 + 21 Damping: 0.707  Matural Frequency: 2.83 rad/zec

To save the compensator design, select Export from the File menu. This opens the SISO
Tool Export. Select Compensator C in the Component column. To change the export
name, double-click in the cell for Compensator C and change the name to say PD. Click
on the Export to Workspace button. Typing PD at MATLAB prompt the PD controller
is printed.

Zero/pole/gain:

10.0157 (s+2.397)

Thus the PD controller is approximately 24 +10s .

From Tools Menu select Loop responses/Close-Loop Step to obtain the step response.
Right-click on the plot, and select Characteristics and then Rise Time and Peak
Overshoot. Left click on the blue dots, this will display the time-domain specifications
shown in the Figure below.

Also note that the open-loop Bode plot displays the compensated system gain margin and
phase margin.
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Right-click on the plat areas for more options.

Example 3

K.(s+z))

(s+py)

For the system in Example 1 Design a phase-lead compensator C(s) = for the

following time-domain specifications.

¢ Dominant poles damping ratio § =0.707
e Dominant poles settling time of ¢, =2 seconds
t,=4r=2 =  7=0.5 second

(o, =—=—=2,and 6 =coc ' (0.707) = 45°
z 0.5
Therefore

The graphical root locus is a trail and error procedure. In this procedure we select the
controller zero and we use the given constraints too find the location of controller poles
and its dc gain. For this example select the zero at —1.75.

To make the plant model and start the SISO Design Tool, at the MATLAB prompt type

>>Gp=tf(1, [1 7 10 0])
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>> sisotool

An empty SISO Design Tool opens. Select Import Model under the File menu. This
opens the Import System Data dialog box. Select Gp and click on the arrow button to
place it in the G field. Click OK. The root locus and open-loop Bode diagrams are
displayed in the plot regions.

To place a pair of complex poles on your diagram at a damping ratio of 0.707, select
Design Constraints and then New from the right-click menu in the root locus. This
opens the Design Constraints editor. In the damping ratio field enter 0.707. This results
in a pair of shaded rays at the desired slope. To add a settling time constraint, reopen the
New Constraint window and choose settling time from the pull-down menu set it’s filed
to 2. Place the curser next to the controller C(s) and click to open its dialog box. In the
Edit Compensator C type —1.75 for a Real Zero. Also, add a real pole, turn on the pole x
on the toolbar and place the pole’\ x on the real axis to the right of the pole with the
largest magnitude. Move the closed-loop pole up the loci towards the intersection of

¢ and 7 constraints. You can turn on the Mouse zoom and place a square in the area

containing the controller zero, pole and the closed loop pole s,. Adjust the pole position

on the real axis and at the same time hold the left mouse and drag the closed-loop pole
until the pole is placed at the desired location as appears on the bottom panel.
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Drag thig clozed-loop pole along the locus to adjust the loop gain.
Current lozation: -2.01 + 21 Damping: 0708 Matural Frequency: 2.84 rad/sec

To save the compensator design, select Export from the File menu. This opens the SISO
Tool Export. Select Compensator C in the Component column. To change the export
name, double-click in the cell for Compensator C and change the name to say PhLead.
Click on the Export to Workspace button. Typing PhLead at MATLAB prompt the
phase lead controller is printed.

Zero/pole/gain:
64.2588 (s+1.75)
(s+8.023)
64(s+1.75)
(s+8)
From Tools Menu select Loop responses/Close-Loop Step to obtain the step response.
Right-click on the plot, and select Characteristics and then Rise Time and Peak

Overshoot. Left click on the blue dots, this will display the time-domain specifications
shown in the Figure below.

Thus the phase-lead controller is approximately
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